General Discussion Triathlon Talk » Has anyone updated their Garmin 910? Rss Feed  
Moderators: jmk-brooklyn, Ron Reply
2013-08-01 12:57 PM

User image

NH
Subject: Has anyone updated their Garmin 910?
I see that a new firmware update is available - 2.8. Has anyone updated to this version? I haven't had any real issues with 2.7 but I see there is a fix for a serious multi-sport mode problem with losing the location after the swim.


2013-08-01 1:52 PM
in reply to: wbayek

User image

Master
3521
20001000500
Gold member
Subject: RE: Has anyone updated their Garmin 910?
If that issue is fixed, I will be updating in a hurry.  That particular problem has really pissed me off in my past 2 races.  I thought it was something that I was doing wrong.  I emailed support but got no response.
2013-08-01 1:59 PM
in reply to: wbayek

User image

Member
118
100
Los Gatos
Subject: RE: Has anyone updated their Garmin 910?
I'm on firmware 2.8 and can confirm the swim location issue is still there.

In fact, it has arguably got worse - with 2.7, it would frequently collect an incomplete series of datapoints (and then just "join them together", thus producing an inaccurate total distance), But with 2.8, on my OWS this last weekend, it collected *zero* swim location data!!

2013-08-01 4:41 PM
in reply to: wbayek

User image

Master
1981
1000500100100100100252525
Silver member
Subject: RE: Has anyone updated their Garmin 910?
I don't want to hijack, but has anyone successfuly used multisport in a race? I have tried it in 4 races and never gotten it right. I didn't try transition splits just to keep it simple. I just assumed I was doing something wrong but now I might have something else to blame.
2013-08-01 6:32 PM
in reply to: pschriver

User image

Pro
5268
50001001002525
Harrisburg, PA
Subject: RE: Has anyone updated their Garmin 910?
Originally posted by pschriverI don't want to hijack, but has anyone successfuly used multisport in a race? I have tried it in 4 races and never gotten it right. I didn't try transition splits just to keep it simple. I just assumed I was doing something wrong but now I might have something else to blame.
Knock on wood, but mine has worked flawlessly in the four races I've used it - one with an indoor pool swim, and three ows. IMO, a lot of the issues seem to be operator error. Turn on the 910 before the race to connect to as many satellites as possible. Hold the lap button 3 seconds to ensure your last session was saved and cleared. Set it to begin auto Multisport. Keep it above the water to maintain signal until the gun goes off (this means treading water with one hand out of the water if it's a deep water start). Press start when the gun goes off. Press the lap button every time you cross a timing mat, including the finish line. Hold the lap button 3 seconds to save the data before uploading.
2013-08-01 6:43 PM
in reply to: #4818883

User image


484
100100100100252525
Subject: RE: Has anyone updated their Garmin 910?
I have had no issues with mine and it works great in races. I wasn't having issues with it losing the satellites in multisport mode though.


2013-08-01 7:38 PM
in reply to: wbayek

User image

Subject: RE: Has anyone updated their Garmin 910?

I got my 910 in October 2012.  It worked fine for all runs (don't use it for biking).  Updated to 2.7 when it came out and did my first OWS with it and lost signal in the water.  Did my first swim/run brick with it and I ended up in Africa.

I did the master reset, and it seems to have fixed the issue for me.  Worked fine for a HIM in June.

I updated to 2.8 when it came out and it's worked fine in training and did a race this past weekend and it worked fine.  Actually, it was exceptional.  Swim was supposed to be 750m (820y) and it measured 816y.  Bike was known to be 24.3 miles and it recorded 24.27.  Run was known to be 6.05 and it recorded 6.05.  All my HR, power, elevation data was spot on well.

2013-08-01 8:38 PM
in reply to: wbayek

User image

Champion
6045
5000100025
New York, NY
Gold member
Subject: RE: Has anyone updated their Garmin 910?
due to the issue you describe of being off the coast of Africa after the swim I down graded to 2.6 before using my 910 in a tri. the latest version is supposed to fix that issue so I upgraded and will be using multisport sunday Over on ST there has been success
2013-08-01 9:11 PM
in reply to: pschriver

User image

Master
1922
1000500100100100100
Midlothian, VA
Subject: RE: Has anyone updated their Garmin 910?
Here's one of my race swims. I dare say it looks pretty spiffy and I sighted well...

http://connect.garmin.com:80/activity/embed/180803792

2013-08-02 12:30 AM
in reply to: TriToy

User image

Pro
5268
50001001002525
Harrisburg, PA
Subject: RE: Has anyone updated their Garmin 910?
Originally posted by TriToydue to the issue you describe of being off the coast of Africa after the swim I down graded to 2.6 before using my 910 in a tri. the latest version is supposed to fix that issue so I upgraded and will be using multisport sunday Over on ST there has been success
. FYI - Anecdotally, the "Africa" bug can apparently be caused by allowing the 910 to lose signal prior to the start by having it under water as I described in my post above.
2013-08-02 12:51 AM
in reply to: TriMyBest

User image

Subject: RE: Has anyone updated their Garmin 910?

Originally posted by TriMyBest
Originally posted by TriToydue to the issue you describe of being off the coast of Africa after the swim I down graded to 2.6 before using my 910 in a tri. the latest version is supposed to fix that issue so I upgraded and will be using multisport sunday Over on ST there has been success
. FYI - Anecdotally, the "Africa" bug can apparently be caused by allowing the 910 to lose signal prior to the start by having it under water as I described in my post above.

That was my experience as well.  However, my 910 was losing signal right in the middle of my swim.  I could feel it vibrate as I was stroking and only when I finished my swim did I see the "reception lost" message on the screen.  This happened on 3 consecutive OWS...all losing connection in the middle of the swim.  When I did the master reset, it seemed to cure the reception lost problem even though I was on the same firmware.

I should correct my post above that firmware 2.7 worked fine for my HIM.  Technically I set up my multisport for that race as a Pool Swim followed by bike and run because I didn't want to worry about the signal being lost during the swim and then losing bike and run data.  But for my last race using 2.8, the multisport worked fine using the OWS/Bike/Run.



2013-08-02 4:24 AM
in reply to: Jason N

User image

Master
3144
2000100010025
Just South of Boston
Silver member
Subject: RE: Has anyone updated their Garmin 910?
I did and the elevation issue is still there. My run today started at 35,000 feet, apparently.
2013-08-02 8:14 AM
in reply to: Mike_D

User image

Expert
1199
1000100252525
Is this Heaven? No, it's Iowa.
Subject: RE: Has anyone updated their Garmin 910?

I've had good luck with the 910 Multi Sport mode during tris and during normal OWS workouts.  Although, I'm suspicious about a recent triathlon that I competed.  It looks okay(ish) on the map but I'm not certain that the distance ended up correct.

I'm still on 2.6 and need to update it though.  Since I have AG Nationals next weekend, I probably won't mess with it until I'm back.

 

2013-08-02 10:51 AM
in reply to: TriMyBest

User image

Champion
6045
5000100025
New York, NY
Gold member
Subject: RE: Has anyone updated their Garmin 910?
Originally posted by TriMyBest

Originally posted by TriToydue to the issue you describe of being off the coast of Africa after the swim I down graded to 2.6 before using my 910 in a tri. the latest version is supposed to fix that issue so I upgraded and will be using multisport sunday Over on ST there has been success
. FYI - Anecdotally, the "Africa" bug can apparently be caused by allowing the 910 to lose signal prior to the start by having it under water as I described in my post above.


I used 2.6 for Williamsburg and though the swim clearly is not accurate I did not then land off the coast of africa despite during the swim feeling the vibration of lost signal a gazillion times.

since going to 2.8, have done OWS with no issues of signal but have not yet used multisport. will this sunday for a small sprint
New Thread
General Discussion Triathlon Talk » Has anyone updated their Garmin 910? Rss Feed  
RELATED POSTS

Does anyone's Garmin 910 Elevation work?

Started by TTom
Views: 1391 Posts: 20

2013-08-02 12:59 PM CDK

Does the Garmin 910 sync with BT yet?

Started by Z-dog
Views: 332 Posts: 3

2012-05-09 12:31 AM Z-dog

garmin 310 vs 910

Started by turtlegirl
Views: 2751 Posts: 10

2012-03-28 9:36 PM powerman

Garmin 910 xt swimming

Started by garrunning
Views: 4736 Posts: 10

2012-02-28 12:54 PM ironultrared

Garmin 310/910 or bike computer and gps watch

Started by garrunning
Views: 806 Posts: 4

2012-01-01 4:17 PM PeteDin206
RELATED ARTICLES
date : November 12, 2009
author : Coach AJ
comments : 0
In this review, we put the Garmin Forerunner 405 and the Suunto T6C heart-rate and GPS watches through the wringers.
 
date : September 28, 2009
author : Coach AJ
comments : 0
New products from Athlete 3, Fuji, Garmin, Kestrel, LiveStrong, Reynolds, Scott, Specialized, Shimano and Vision Tech
date : June 18, 2008
author : Team BT
comments : 3
Easily transfer your workout data from your Garmin, Polar, Timex and more directly into your BT training log. Eliminate the manual entries. Save time!
 
date : March 26, 2008
author : Team BT
comments : 0
Instructions on how to directly upload routes from your Garmin training device into your training logs.